Connectivity Issues
Incident Report for Clik
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 16:31 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 19, 2024 - 16:01 BST
Investigating
We are currently experiencing connectivity issues due to the global CrowdStrike outage. This could affect some customers across our services. We are working to get our systems online and will update this page when we have further news.
Posted Jul 19, 2024 - 09:02 BST
This incident affected: Clik Jobs Sync, Clik Cert Electrical Sync, App Notifications, Clik Remote DNS, Text messaging, and Clik Cert.