Clik Cloud speed issues
Incident Report for Clik
Resolved
This incident has been resolved.
Posted Oct 10, 2019 - 12:21 BST
Investigating
We are currently investigating this issue.
Posted Oct 10, 2019 - 12:18 BST
This incident affected: Clik Jobs Sync.