Network Outage
Incident Report for Clik
Resolved
This incident has been resolved.
Posted Nov 14, 2024 - 20:56 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2024 - 19:56 GMT
Investigating
We are currently investigating this issue.
Posted Nov 14, 2024 - 19:36 GMT
This incident affected: Clik Jobs Sync, Clik Cert Electrical Sync, App Notifications, Text messaging, and Clik Cert.